Ask a Question

Can't reconnect to Pritunl after changing WiFi network

Hey, when wifi network changed, Pritunl unable to reconnect unless I stop the openvpn and restart it. Is there any way to make Pritunl reconnect automatically after wifi is changed? Thanks

Does the pritunl client support connecting to Wireguard VPNs (specifically Pritunl/Wireguard)?

After reading through features on the client.pritunl.com site - it appears on first blush that the pritunl client only supports connecting to OpenVPN servers. Does the Pritunl client software support connecting to Wireguard VPN servers? More specifically, Pritunl / Wireguard VPN based servers? Thank you.

SSO getting group membership and setting groups

We would like to use SSO and in SSO define what groups the user belongs to...so that that person get access to the appropiate resources behind the VPN. How is this possible with Pritunl, can it get groups from SSO? At the moment it seems you have to define an Org from SSO which puts the user on Pritun in the correct pritunl org which gives server access, but this doesnt seem like matches the same pattern.

Pritunl TOTP

Is Pritunl compatible with AWS Cognito?

Error in management socket thread Traceback

Hi All, I am getting error, i have tried all option and suggestion given still have no luck. [email protected]:~# sudo cat /dev/net/tun cat: /dev/net/tun: No such file or directory [evening-refuge-1513][2022-04-03 23:56:30,914][ERROR] Error in management socket thread Traceback (most recent call last): File "/usr/lib/pritunl/lib/python3.6/site-packages/pritunl/server/instance_com.py", line 286, in _socket_thread self.connect() File "/usr/lib/pritunl/lib/python3.6/site-packages/pritunl/server/instance_com.py", line 372, in connect self.sock.connect(self.socket_path) ConnectionRefusedError: [Errno 111] Connection refused server_id = "hide me" instance_id = "hide me" socket_path = "/var/run/pritunl_hide me.sock"

Adapter 'Ethernet 2' not found

When trying to connect with Pritunl on a Windows 11 laptop, if the ethernet adapter is enabled, Pritunl will fail to connect with the following. If I disable or remove the ethernet adapter, it will connect without issue. Data Channel: using negotiated cipher 'AES-256-GCM' Outgoing Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key Incoming Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key open_tun Adapter 'Ethernet 2' not found Exiting due to fatal error I have: - Blown out all adapters, tap adapters, drivers, etc. and manually reinstalled them. - I have reset all factory drivers and re-installed/updated them. - I have completely scrubbed Pritunl from the machine along with the tap adapters, wan miniports, etc, and re-installed. Previous solutions of reinstalling/renaming/etc have not worked: https://docs.pritunl.com/discuss/5c050be056a57201d9e72daa https://docs.pritunl.com/discuss/6038cdcf0d04ba006fae8aef Given that Windows 11 is fairly new, has anyone else ran into this on a Win 11 machine? Apologies if this has been posted multiple times, this site is difficult to navigate.


This discussion section will be closed and replaced with https://forum.pritunl.com

Server not accessable when its connect to pritunl VPN

Hello i have 2 Server/Clients First Server is the VPN Server Real Remote IP: 45.xxx.xxx.20 VPN Range: Domain: vpn.example.com binded on 45.xxx.xxx.20 Second Server is an OnlyOffice Server Real Remote IP: 45.xxx.xxx.25 VPN Client IP: Domain: office.example.com binded on 45.xxx.xxx.25 My Pc connected via printunl to the vpn Server Real remote Ip: dynamic VPN Client IP: My Iphone isnt connected to the vpn server Real Remote ip: dynamic celluar My Pc -> connected to office.example.com -> works fine IPhone -> connected to office.example.com -> failed, timeout How i can fix that the onlyoffice Server is reachable inside the vpn and over the real remote ip without the VPN Tunnel?

Is there a way to get a notification if the licence expires?

E.g. if the associated credit card expires and isn't updated with stripe, can we get an email notification when it fails to charge the card? Alternatively is there a way to alert on the licence expiry date getting close using datadog? Somewhere the date's located on the instance we can monitor?

Is it possible to add server routes for every IP except for one?

I am wanting to add the route, except for only one IP address. Is this possible to do? And if not, are Rhee any workarounds?